12.171 cursos gratis
8.751.247 alumnos
Facebook Twitter YouTube
Busca cursos gratis:

Manual de programación

Autor: Manuel Angel Lopez Zurita
Curso:
8,33/10 (3 opiniones) |4300 alumnos|Fecha publicaciýn: 31/01/2008
Envýa un mensaje al autor

Capýtulo 6:

 Sentencia condicional

Esta sentencia nos permite elegir un conjunto de instrucciones en función de que se cumpla o  no una condición; cuando se ejecuta esta condición, la expresión que se evalúa debe ser de tipo Booleano (Verdadero o Falso).

Dentro de una sentencia condicional sólo se puede ejecutar una rama de las condiciones.

Vea los siguientes ejemplos de sentencias condicionales:

1.            programa estado_temperatura
2.                definir temperatura como entero
3.                temperatura=leer_teclado()
4.                /*muestra un texto por pantalla indicando la temperatura*/
5.                si temperatura<0 entonces
6.                       escribir_pantalla("Temperatura bajo cero")
7.                si temperatura>=0 y temperatura<20 entonces
8.                       escribir_pantalla("Temperatura fría")
9.                si temperatura>=20 y temperatura<30 entonces
10.                    escribir_pantalla("Temperatura normal")
11.             si no
12.                    escribir_pantalla("Temperatura alta")
13.             finsi
14.            finprograma

La función escribir_pantalla muestra por pantalla lo que se indica entre paréntesis.

Otro ejemplo de sentencia condicional:

1.            programa mostrar_dia
2.                definir dia_semana como entero
3.        
4.                escribir_pantalla("Indique el día de la semana")
5.                dia_semana=leer_teclado()
6.        
7.                si (dia_semana==1) entonces
8.                       escribir_pantalla("Lunes")
9.                si (dia_semana==2) entonces
10.                    escribir_pantalla("Martes")
11.             si (dia_semana==3) entonces
12.                    escribir_pantalla("Miércoles")
13.             si (dia_semana==4) entonces
14.                    escribir_pantalla("Jueves")
15.             si (dia_semana==5) entonces
16.                    escribir_pantalla("Viernes")
17.             si (dia_semana>=6) entonces
18.                    escribir_pantalla("Día festivo")
19.                    si (dia_semana==6) entonces
20.                           escribir_pantalla("Sábado")
21.                    si (dia_semana==7) entonces
22.                           escribir_pantalla("Domingo")
23.                    finsi
24.             finsi
25.            finprograma

En este ejemplo se puede ver como, dentro de una sentencia condicional, se puede incluir otra sentencia condicional. Las comparaciones de igualdad se hace con el símbolo ==, y las comparaciones de diferente, se hacen con <>.

Otro ejemplo:

1.            programa valor_absoluto
2.                definir a como entero
3.        
4.                escribir_pantalla("Indique un número")
5.                a=leer_teclado()
6.                si (a<0) entonces
7.                       b=a*(-1)
8.                si no
9.                       b=a
10.             finsi
11.             /*b posee el valor absoluto de a*/
12.             escribir_pantalla(convertir_cadena(b))
13.            finprograma

La conversión de una variable entera a cadena se realiza con la función convertir_cadena.

Otro ejemplo:

1.            programa par_impar
2.                definir a como entero
3.        
4.                a=leer_teclado()
5.                si (a resto 2==0) entonces
6.                       escribir_pantalla(convertir_cadena(a) + " es un número par")
7.                si no
8.                       escribir_pantalla(convertir_cadena(a) + " es un número impar")
9.                finsi
10.            finprograma

La concatenación de cadenas se realiza con el operador +.

Capýtulo siguiente - Sentencia bucle (parte 1)
Capýtulo anterior - Asignación

Nuestras novedades en tu e-mail

Escribe tu e-mail:



MailxMail tratarý tus datos para realizar acciones promocionales (výa email y/o telýfono).
En la polýtica de privacidad conocerýs tu derechos y gestionarýs la baja.

Cursos similares a Manual de programación



  • Výdeo
  • Alumnos
  • Valoraciýn
  • Cursos
1. Action Script 3. Lenguaje de programación
Action script 3 . Este curso de informática fue realizado especialmente para las... [04/05/11]
274
Curso con video
2. Visual Basic 6. Crear teclado virtual (programación)
Curso de Visual Basic 6.0 . Seguimos aprendiendo programación en Visual Basic y... [14/01/11]
5.049
Curso con video
3. Algoritmos en QBASIC. Manual
Este manual de QBASIC es una colección linkografica y bibliográfica sobre el uso... [26/10/09]
12.730  

ýQuý es mailxmail.com?|ISSN: 1699-4914|Ayuda
Publicidad|Condiciones legales de mailxmail