12.171 cursos gratis
8.751.247 alumnos
Facebook Twitter YouTube
Busca cursos gratis:

Manual de programación

Autor: Manuel Angel Lopez Zurita
Curso:
8,33/10 (3 opiniones) |4300 alumnos|Fecha publicaciýn: 31/01/2008
Envýa un mensaje al autor

Capýtulo 9:

 Sentencia bucle (parte 3)

Otra estructura de bucle que se utiliza frecuentemente es cuando se sabe cuántas repeticiones de código se van a realizar antes de que empiece a ejecutarse el bucle.

Cuenta atrás desde 10:

1.            programa cuenta_atras
2.                definir numero como entero
3.        
4.                para numero=10 hasta 1
5.                       escribir_pantalla(convertir_cadena(numero))
6.                finpara
7.            finprograma

Sumatorio de todos los números inferiores al indicado:

1.            programa sumatorio
2.                definir resultado como entero
3.                definir numero_leido como entero
4.                definir indice como entero
5.        
6.                escribir_pantalla("Indique el número")
7.                numero_leido=leer_teclado()
8.                resultado=0
9.                para indice=1 hasta numero_leido
10.                    resultado=resultado + indice
11.             finpara
12.             escribir_pantalla("El sumatorio de 1 hasta " + __
13.             convertir_cadena(numero_leido) + " es " + __
14.             convertir_cadena(resultado) +".")
15.            finprograma

Definir los valores de y de la función y = ax+b, en un rango desde x = -100 hasta x=100.

1.            programa valores_funcion
2.                definir a como entero
3.                definir b como entero
4.                definir indice como entero
5.                definir resul como entero
6.        
7.                escribir_pantalla("Indique el valor de a")
8.                a=leer_teclado()
9.                escribir_pantalla("Indique el valor de b")
10.             b=leer_teclado()
11.             para indice=-100 hasta 100
12.                    resul=a*indice+b
13.                    escribir_pantalla("X=" + convertir_cadena(indice) + __
14.                     "Y=" + convertir_cadena(resul))
15.             finpara
16.            finprograma

Escribir los primeros 15 números de la serie de Fibonacci (ai=ai-1+ai-2;a1=1;a0=1)

1.            programa fibonacci
2.                definir ai2 como entero
3.                /*ai2=ai-2*/
4.                definir ai1 como entero
5.                /*ai1=ai-1*/
6.                definir ai como entero
7.                /*ai=ai*/
8.                definir indice como entero
9.                para indice=1 hasta 15
10.                    ai=ai1+ai2
11.                    escribir_pantalla("A" + convertir_cadena(indice+1) +" es " __
12.                    convertir_cadena(ai))
13.             /*el indice+1 es debido a que el primer número de fibonacci*/
14.             /*calculado es el 2, que se da cuando el indice es 1*/
15.                    ai2=ai1
16.                    ai1=ai
17.             finpara
18.            finprograma

Capýtulo anterior - Sentencia bucle (parte 2)

Nuestras novedades en tu e-mail

Escribe tu e-mail:



MailxMail tratarý tus datos para realizar acciones promocionales (výa email y/o telýfono).
En la polýtica de privacidad conocerýs tu derechos y gestionarýs la baja.

Cursos similares a Manual de programación



  • Výdeo
  • Alumnos
  • Valoraciýn
  • Cursos
1. Action Script 3. Lenguaje de programación
Action script 3 . Este curso de informática fue realizado especialmente para las... [04/05/11]
274
Curso con video
2. Visual Basic 6. Crear teclado virtual (programación)
Curso de Visual Basic 6.0 . Seguimos aprendiendo programación en Visual Basic y... [14/01/11]
5.049
Curso con video
3. Algoritmos en QBASIC. Manual
Este manual de QBASIC es una colección linkografica y bibliográfica sobre el uso... [26/10/09]
12.730  

ýQuý es mailxmail.com?|ISSN: 1699-4914|Ayuda
Publicidad|Condiciones legales de mailxmail