12.171 cursos gratis
8.751.247 alumnos
Facebook Twitter YouTube
Busca cursos gratis:

Manual de programación

Autor: Manuel Angel Lopez Zurita
Curso:
8,33/10 (3 opiniones) |4300 alumnos|Fecha publicaciýn: 31/01/2008
Envýa un mensaje al autor

Capýtulo 8:

 Sentencia bucle (parte 2)

Otro ejemplo, en el que se lee un fichero y se cuenta cuantas letras "a" hay en el fichero:

1.            programa lectura_fichero
2.                definir fd como entero
3.                definir contador como entero
4.                definir leido como caracter
5.        
6.                fd=abrir_fichero("c:\fichero.txt")
7.                /*inicializar la variable que cuentas a*/
8.                contador=0
9.                mientras (fin_fichero(fd)==falso)
10.                    leido=leer_fichero(fd)
11.                    si (leido=="a" O leido=="A") entonces
12.                           /*se encontro una a con lo que se incrementa el contador*/
13.                           contador=contador+1
14.                    finsi
15.             finmientras
16.             cerrar_fichero(fd)
17.             escribir_pantalla("Se leyeron " + convertir_cadena(contador) + __
18.              " letras a en el fichero")
19.            finprograma

En este ejemplo se deben puntualizar varias cosas:

Para poder acceder a un fichero primero se debe abrir el fichero con la función abrir_fichero. Esta función automáticamente retorna un número para poder identificar, dentro del programa, a qué archivo nos estamos refiriendo (por ejemplo, para poder identificarlo en la función cerrar_fichero si hubiera más de uno abierto) Cuando se abre un fichero en un programa, antes de finalizar el programa se debe de cerrar el fichero con la función cerrar_fichero. Cuando una sentencia de código no quepa en una línea se pondrá el símbolo __

Cálculo del factorial:

1.            programa factorial
2.                definir factorial como entero
3.                definir numero como entero
4.                definir numero_inicial como entero
5.        
6.                factorial=1
7.                escribir_pantalla("Indique el número")
8.                numero=leer_teclado()
9.                mientras (numero<=1)
10.                    factorial=factorial*numero
11.                    numero=numero-1
12.             finmientras
13.             escribir_pantalla("El factorial de " + __
14.             convertir_cadena(numero_inicial) + " es " + __
15.             convertir_cadena(factorial))
16.            finprograma

Capýtulo siguiente - Sentencia bucle (parte 3)
Capýtulo anterior - Sentencia bucle (parte 1)

Nuestras novedades en tu e-mail

Escribe tu e-mail:



MailxMail tratarý tus datos para realizar acciones promocionales (výa email y/o telýfono).
En la polýtica de privacidad conocerýs tu derechos y gestionarýs la baja.

Cursos similares a Manual de programación



  • Výdeo
  • Alumnos
  • Valoraciýn
  • Cursos
1. Action Script 3. Lenguaje de programación
Action script 3 . Este curso de informática fue realizado especialmente para las... [04/05/11]
274
Curso con video
2. Visual Basic 6. Crear teclado virtual (programación)
Curso de Visual Basic 6.0 . Seguimos aprendiendo programación en Visual Basic y... [14/01/11]
5.049
Curso con video
3. Algoritmos en QBASIC. Manual
Este manual de QBASIC es una colección linkografica y bibliográfica sobre el uso... [26/10/09]
12.730  

ýQuý es mailxmail.com?|ISSN: 1699-4914|Ayuda
Publicidad|Condiciones legales de mailxmail