12.171 cursos gratis
8.751.247 alumnos
Facebook Twitter YouTube
Busca cursos gratis:

Manual de programación

Autor: Manuel Angel Lopez Zurita
Curso:
8,33/10 (3 opiniones) |4300 alumnos|Fecha publicaciýn: 31/01/2008
Envýa un mensaje al autor

Capýtulo 7:

 Sentencia bucle (parte 1)

Un bucle (iteración) es una estructura en la que se ejecutan un conjunto de instrucciones hasta que deje de cumplirse una condición determinada.

Dentro del bucle se deben ejecutar instrucciones para que deje de cumplirse dicha condición; si estas sentencias no existen, entonces el bucle será un bucle infinito.

No tiene por qué darse el caso de que se ejecuten las instrucciones que hay dentro del bucle.

En el siguiente ejemplo, se lee un número por teclado y se decrementa ese número de 1 en 1 hasta que deja de ser >1.

1.            programa primer_bucle
2.                definir a como real
3.        
4.                a=leer_teclado()
5.                mientras (a>1)
6.                       a=a-1.0
7.                finmientras
8.                /*se sale cuando a<=1, o lo que es lo mismo, la negación de a>1 */
9.            finprograma

Fíjese que si el número leído es, por ejemplo, -3, no se ejecutará ninguna línea dentro del bucle.

Si la sentencia que hay en la línea 3 no existiera e inicialmente la variable a fuera mayor que 1 entonces habría un bucle infinito.

1.            programa bucle_infinito
2.                definir a como real
3.                definir b como real
4.        
5.                a=leer_teclado()
6.                mientras (a>1)
7.                       b=a
8.                finmientras
9.                /*se sale cuando a<=1, o lo que es lo mismo, la negación de a>1 */
10.            finprograma

Capýtulo siguiente - Sentencia bucle (parte 2)
Capýtulo anterior - Sentencia condicional

Nuestras novedades en tu e-mail

Escribe tu e-mail:



MailxMail tratarý tus datos para realizar acciones promocionales (výa email y/o telýfono).
En la polýtica de privacidad conocerýs tu derechos y gestionarýs la baja.

Cursos similares a Manual de programación



  • Výdeo
  • Alumnos
  • Valoraciýn
  • Cursos
1. Action Script 3. Lenguaje de programación
Action script 3 . Este curso de informática fue realizado especialmente para las... [04/05/11]
274
Curso con video
2. Visual Basic 6. Crear teclado virtual (programación)
Curso de Visual Basic 6.0 . Seguimos aprendiendo programación en Visual Basic y... [14/01/11]
5.049
Curso con video
3. Algoritmos en QBASIC. Manual
Este manual de QBASIC es una colección linkografica y bibliográfica sobre el uso... [26/10/09]
12.730  

ýQuý es mailxmail.com?|ISSN: 1699-4914|Ayuda
Publicidad|Condiciones legales de mailxmail