12.170 cursos gratis
8.787.274 alumnos
Facebook Twitter YouTube
Busca cursos gratis:

Curso básico de Excel

Autor: Faustino Acosta
Curso:
9/10 (2 opiniones) |3770 alumnos|Fecha publicación: 10/01/2011
Envía un mensaje al autor

Capítulo 10:

 Las funciones en Excel

Una función es una fórmula ya escrita y preparada para realizar cálculos y simplificar el uso de fórmulas extensas. Las funciones tienen un nombre propio y existen multitud de funciones. Imagínate sumar un rango de 200 celdas con una fórmula del tipo =A1+A2+A3+A4...

Existen funciones que realizan complejos cálculos financieros, estadísticos, matemáticos, etc, y que permiten ahorrar trabajo y tiempo en la escritura de una fórmula.

Sintaxis de una función.- Las funciones deben mantener unas reglas de sintaxis tal y como se indica en el siguiente ejemplo: =SUMA(A1:A200;100)

En el ejemplo, se sumará todo el rango A1:A200 y aparte el número 100. Es decir, que dentro de los paréntesis que forman el contenido de la función, hay dos argumentos a sumar.

La función Autosuma: Es quizá la función más utilizada en una hoja de cálculo. Por ello, Excel proporciona un botón exclusivo para la función Autosuma en la barra de herramientas.

Para utilizar una función, podemos escribirla manualmente o bien utilizar el Asistente para funciones que veremos posteriormente y que nos irá guiando paso a paso en la construcción de la función.

1.     Escribe en una hoja nueva unos cuantos números y después coloca el cursor bajo esa misma lista:

Las funciones

2.     Pulsa el botón Autosuma situado en la barra de herramientas estándar: Las funciones

Observa que Excel detecta lo que queremos sumar y lo marca con puntos suspensivos intermitentes. Ahora podemos aceptar pulsando Intro o bien seleccionar con el mouse la zona que queremos sumar.

3.     Pulsa Intro.

Otra forma de hacerlo es la siguiente:

4.     Borra el contenido de la celda que contiene la fórmula.

5.     Selecciona toda el área numérica, la última celda incluida:

Las funciones

1.     Pulsa el botón Autosuma.

En este caso, marcamos directamente el rango que queremos sumar, por lo que Excel lo suma directamente. Con el cursor situado en la celda que contiene la fórmula, observa la barra de fórmulas.

Las funciones

La función tiene entre paréntesis la celda inicial del rango a sumar y la celda final separadas por dos puntos. Desde aquí podemos modificar manualmente el rango.

La función promedio: Otra interesante función es la llamada =PROMEDIO(). Funciona exactamente igual que la suma, pero no existe ningún botón; por lo que debemos introducirla manualmente. Cuando introducimos una función mediante el teclado, podemos escribirla por completo o hacer lo siguiente:

1.     Borra el contenido de la última fórmula

2.     Escribe lo siguiente:=PROMEDIO(

3.     Selecciona con el mouse el rango de números. Fíjate como la fórmula va tomando dicho rango y se va escribiendo sola.

4.     Cierra el paréntesis escribiéndolo a mano.

5.     El resultado obtenido es la media de los datos numéricos.

El asistente para funciones: Existen muchos tipos de funciones; matemáticas, estadísticas, de fecha, científicas, etc, alguna de las cuales contiene una sintaxis bastante más difícil que la autosuma, por ejemplo. Existen funciones que realizan complejos cálculos y que tan sólo nos piden unos datos específicos.

Si no recordamos la sintaxis de una función, podemos hacerlo con el Asistente de funciones el cual, nos guiará paso a paso hasta obtener el resultado buscado.

1.     Borra el contenido de la última fórmula y sitúa el cursor en ella.

2.     Pulsa el botón Pegar función de la barra de herramientas estándar Las funciones

3.     Pulsa a la izquierda la opción Estadísticas.

4.     Sube la lista deslizable de la ventana derecha hasta encontrar la función PROMEDIO y pulsa un click sobre ella.

5.     Observa la línea de estado de la ventana; nos explica para qué sirve esa función. Acepta.

6.     Ahora nos pide qué celdas o rango de celdas queremos utilizar para saber el resultado del promedio de datos. Podemos pulsar click en las celdas que nos interesen, escribirlas a mano o bien seleccionar un rango de datos de la hoja. Selecciona el rango adecuado y acepta.

OTRAS FUNCIONES MAX, MIN

En esta unidad didáctica veremos otras funciones MAX, MIN

1.     Haz una sencilla hoja de cálculo como la que sigue:

Otras funciones MAX, MIN

2.     Sitúa el cursor en D4 y escribe la fórmula: =B4*C4. Cópiala hacia abajo.

3.     Escribe al lado de la hoja las nuevas celdas de texto:

Otras funciones MAX, MIN

4.     Escribe las fórmulas de las celdas:

Celda                Fórmula

  F3           =SUMA(D4:D9)
  F4           =PROMEDIO(D4:D9)
  F5           =MAX(D4:D9)
  F6           =MIN(D4:D9)
  F7           =CONTAR(D4:D9)

1.     Selecciona el rango de los resultados y conviértelo en formato moneda.

Como habrás imaginado, hemos obtenido el valor máximo, mínimo y además hemos contado el número de elementos numéricos que aparecen en el rango D4:D9.

Sugerir una función: En ocasiones, podemos conocer el cálculo que queremos realizar, pero no si existe alguna función que Excel nos pueda aportar para obtener el resultado.

En este caso, podemos hacer que sea el propio Excel el que nos sugiera una función a utilizar. Cuando ocurra esto, podemos pulsar el botón Pegar función y seguidamente pulsar el botón de ayuda que aparece en la parte inferior del cuadro de diálogo.

Pulsando el botón Ayuda con esta característica podemos escribir una descripción de lo que queremos hacer y posiblemente Excel nos ayude. Por ejemplo:

Pulsa dicho botón y escribe en la casilla que aparece: Desviación típica.

Excel nos muestra una lista de funciones recomendadas para obtener los resultados que buscamos.

Funciones anidadas: Se llaman así aquellas funciones que actúan como argumento de otra función, es decir, que se encuentran dentro de otra función. En el proceso de cálculo, Excel realiza primero el cálculo de la función interior y después, el resultado de la función exterior teniendo ya en cuenta el resultado que se ha obtenido con la función interior.

Por ejemplo, la función: =RAIZ(POTENCIA(20,3))

Primero calculará el resultado de la función interior, o sea, de la potencia, cuyo resultado es 8.000 y luego se calculará el resultado de la exterior, teniendo en cuenta ya este resultado, arrojando como resultado 89.443.

La función =SI(): Una de las funciones más potentes que se utilizan en Excel es la función =SI().

Esta función tiene la siguiente estructura: =SI (condición,verdadero,falso).

Donde condición es una condición que se tiene que cumplir. Si ésta se cumple, se ejecutará verdadero, o en caso contrario, se ejecutará falso.

Por ejemplo: =SI(A3>B12,"Correcto","Incorrecto")

Si la celda A3 es mayor que la celda B12, aparecerá la palabra Correcto. En caso contrario, aparecerá la palabra Incorrecto.

=SI(A1="Bajo mínimos","Quiebra","Normal")

Si la celda A1 contiene la palabra Bajo mínimos, en la celda actual aparecerá la palabra Quiebra. En caso contrario, aparecerá la palabra Normal.

=SI(O(A1=B1,C1=D1),"Bien","Mal")

Aquí ha de cumplirse una de las dos condiciones. Nótese la utilización del operador O.

Capítulo siguiente - El formato de las celdas
Capítulo anterior - Las fórmulas en Excel

Nuestras novedades en tu e-mail

Escribe tu e-mail:



MailxMail tratará tus datos para realizar acciones promocionales (vía email y/o teléfono).
En la política de privacidad conocerás tu derechos y gestionarás la baja.

Cursos similares a Curso básico de Excel



  • Vídeo
  • Alumnos
  • Valoración
  • Cursos
1. Excel 2003. Tutorial básico: fórmulas de Excel
Fórmulas de Excel . En el siguiente tutorial de Excel 2003 vamos a aprender a... [04/05/10]
13.327
Curso con video
2. Excel 2003. Tutorial básico: formato en Excel
Tutorial de Excel 2003 . En este vídeo tutorial de Microsoft Excel , vamos a... [29/04/10]
10.188
Curso con video
3. Excel básico. Funciones de los comandos Deshacer y Rehacer
Este vídeotutorial de Excel básico explica la función de los comandos... [05/04/13]
9
Curso con video

¿Qué es mailxmail.com?|ISSN: 1699-4914|Ayuda
Publicidad|Condiciones legales de mailxmail